ImageImage

losing key packets 9014

Game Questions and Help / Errors and Game Issues
User avatar
GunClap
Retired Clan Member
Retired Clan Member
Posts: 264
Joined: Wed Dec 31, 1969 7:00 pm
Location: In the line of fire...

Post by GunClap » Thu Oct 21, 2010 2:48 am

I tried a very similar method, but on XP home, that didn't work. Although the kicks have become more infrequent, I will still get kicked after about 3 or 4 maps...

Seems it's a service interaction setting that causes the kick, but no user or EvenBalance have been able to pinpoint it yet... I know I haven't... ;/
Image
Your mind is a weapon. Keep it clean, clear and loaded...

User avatar
Scortch
Newbie
Newbie
Posts: 20
Joined: Wed Dec 31, 1969 7:00 pm

Post by Scortch » Tue Oct 26, 2010 6:45 pm

Root, thanks for taking the time set out those instructions. I will only be reinstalling ET as a last resort and they will come in handy if it comes to that. (and only as a last resort because ET doesn't settle so well on my system. Everytime I reinstall the game I have to do it three or four or five times before it will actually work.....dunno why :shrug: )


Here's where I am with this 9014 issue; Yesterday, Even Balance had me download a program called Process Explorer from Microsoft. They gave me detailed instructions on how they wanted me to use it.

I was told:

"I know this is a bit complicated, but it will show everything that's being loaded directly into the game, and that's what we need to know so we can see what is generating this kick."

I have some small hope that this information will help them to finally resolve this.

User avatar
ferapont
Retired Clan Member
Retired Clan Member
Posts: 255
Joined: Wed Dec 31, 1969 7:00 pm
Location: Seattle

Post by ferapont » Tue Oct 26, 2010 7:42 pm

Should some more of us try this method? Do you have some instructions?

User avatar
GunClap
Retired Clan Member
Retired Clan Member
Posts: 264
Joined: Wed Dec 31, 1969 7:00 pm
Location: In the line of fire...

Post by GunClap » Wed Oct 27, 2010 1:53 am

Well, I'm already very familiar with both Process Explorer and dll injection/cross application calls so I'll look into my load when I get back home.

Interesting. EvenBalance seen to think it's a foreign dll, but my concern is that it's actually something like pb querying the dlls just to have say your AV refusing a response because it suspects this to be a malicious request.
Image
Your mind is a weapon. Keep it clean, clear and loaded...

User avatar
SirPing
Newbie
Newbie
Posts: 46
Joined: Wed Dec 31, 1969 7:00 pm
Location: not found

Post by SirPing » Wed Oct 27, 2010 6:32 am

I put to my friend and sis to test the suppose solution and, some days works, other just kick and kick..(PB best soccer player)

Dl this http://www.mediafire.com/?qq1rdepq234yd20
and put on your pb archive
press the exe for "update"
play and beg to the god of your choice

sis say: "have no problem on et and cod except the freeze lag"
Ramon say: "your %&/54 just don't work!!!!" (classic pipope)
and myself just sometimes

good luck
have a nice day :coffee:
revenge achievement..

User avatar
Scortch
Newbie
Newbie
Posts: 20
Joined: Wed Dec 31, 1969 7:00 pm

Post by Scortch » Wed Oct 27, 2010 6:35 am

Fera, I can post the instructions if you want, but all they wanted was a log file. Process Explorer provides a list of all the DLLs that are being loaded into the game. Along with their base addresses and mapped sizes.


I guess Gunclap knows what a lot of that means, but for me, all I can do is provide the file and hope someone at Even Balance sees something in it that leads to a solution.

I'm really not to sure that the answer is there though. This avenue of investigation seems to imply that it is something on the users end that is instigating these kicks. But, I haven't changed any settings or hardware so I don't see how some mysterious DLL could suddenly appear and start generating this kick. The problem is affecting too many people using too many different setups for it to be anything other than a mistake in Even Balance's last update. (or so I surmise)

I will post any more information I get from them here.

User avatar
KrispyKritter
Retired Clan Member
Retired Clan Member
Posts: 977
Joined: Wed Dec 31, 1969 7:00 pm

Post by KrispyKritter » Wed Oct 27, 2010 3:33 pm

Scortch wrote: But, I haven't changed any settings or hardware so I don't see how some mysterious DLL could suddenly appear and start generating this kick. The problem is affecting too many people using too many different setups for it to be anything other than a mistake in Even Balance's last update. (or so I surmise)
The 120135 pb kicks of last year were caused by a change in the Comodo program. This security program would have auto-updates which the user might not be aware of. From the Users' points of view, nothing had changed, but in fact, the software on their systems had changed.

The 9014 kicks did start the same weekend as PunkBuster updates to clients and servers.

My first thought is that we should all send them Process Explorer reports, but then I realized they would be inundated with data. They have probably sent all the complainants the same instructions, so they will have a manageable number of reports to peruse, looking for commonalities amongst them. Perhaps their procedure is automated, based on the reports' format.
KrispyKritter aka Chatty (glitchy finger) Charlie
Image(pcB)

User avatar
KrispyKritter
Retired Clan Member
Retired Clan Member
Posts: 977
Joined: Wed Dec 31, 1969 7:00 pm

Post by KrispyKritter » Wed Oct 27, 2010 4:57 pm

SirPing wrote:I put to my friend and sis to test the suppose solution and, some days works, other just kick and kick..(PB best soccer player)

Dl this http://www.mediafire.com/?qq1rdepq234yd20
and put on your pb archive
press the exe for "update"
play and beg to the god of your choice

sis say: "have no problem on et and cod except the freeze lag"
Ramon say: "your %&/54 just don't work!!!!" (classic pipope)
and myself just sometimes

good luck
have a nice day :coffee:
Your download file is missing the executable "pbsetup.exe". The other files appear to be the same as the ones my manual install produced on 10/4/10. I suggest you download the compressed file to a "PB-Downloads" folder as I did since some of the *.htm files seem to stay in the folder they were uncompressed to. :fball:
KrispyKritter aka Chatty (glitchy finger) Charlie
Image(pcB)

User avatar
SirPing
Newbie
Newbie
Posts: 46
Joined: Wed Dec 31, 1969 7:00 pm
Location: not found

Post by SirPing » Thu Oct 28, 2010 2:46 am

err no, have the same exe, the files are only for "update", I tested it today for 2hrs and pb don't kick me but
thanks a lot :wtg:
revenge achievement..

User avatar
Scortch
Newbie
Newbie
Posts: 20
Joined: Wed Dec 31, 1969 7:00 pm

Post by Scortch » Thu Nov 04, 2010 6:26 am

Well the whole Process Explorer thing wasn't what they needed.

My last note from them said:

" Our coders are willing to make you a trial PB build to test with since we cannot reproduce this problem using the information you have provided. Are you willing to run a trial pbcl.dll in order to see if we can find out why this is happening on your system? "


I answered that I was and I am now waiting for the file.

Again, I will post any updates to this situation here.


As an aside, I cut the tip of my left hand middle finger almost all the way off on a table saw on Monday. So I'll be playing with a bit of a handicap when I try this dll. I expect to do a lot more spawning than I have in a while.

User avatar
ferapont
Retired Clan Member
Retired Clan Member
Posts: 255
Joined: Wed Dec 31, 1969 7:00 pm
Location: Seattle

Post by ferapont » Thu Nov 04, 2010 3:55 pm

table saw accident! disgusting and intriguing.

i think it is funny that they cant reproduce this 9014 problem but X-amount of people a day get kicked for 9014.

it has got to be more than 30 9014 kicks a day, ill say 100 and we can play over/under

User avatar
Simtech
Clan Member
Clan Member
Posts: 812
Joined: Wed Dec 31, 1969 7:00 pm
Location: Baton Rouge, LA

Post by Simtech » Fri Nov 05, 2010 5:34 pm

I saw someone mention leatrix fix on the server today. Said that it worked for him.
Take a look:
http://www.wowinterface.com/downloads/i ... cyFix.html
ImageImage

User avatar
Scortch
Newbie
Newbie
Posts: 20
Joined: Wed Dec 31, 1969 7:00 pm

Post by Scortch » Fri Nov 05, 2010 11:17 pm

I had a read through that info Simtech, I'm going to give that script a trial run. I don't think it could hurt anything anyway.


I didn't have to wait too long to get the "trial PB build" from the folks at Even Balance. I joined the BBA server with it and played until the inevitable 9014 and then emailed a new log file to the support guys. My support ticket was updated and closed today.

The last note from them said:

"Note #14: Thank you - it seems our coders found something on this and are testing a trial build with some server admins, we expect an update soon - let us know if the next ET doesn't resolve this for you."

So now all my tickets have been closed, and it seems a solution is not too far away.I've got my fingers crossed, but I'm not going to go as far as to hold my breath.


...here's hoping.

User avatar
Scortch
Newbie
Newbie
Posts: 20
Joined: Wed Dec 31, 1969 7:00 pm

Post by Scortch » Fri Nov 05, 2010 11:56 pm

Also;

I thought this was interesting...

http://qawet.proboards.com/index.cgi?ac ... ge=3#85846

User avatar
KrispyKritter
Retired Clan Member
Retired Clan Member
Posts: 977
Joined: Wed Dec 31, 1969 7:00 pm

Post by KrispyKritter » Sat Nov 06, 2010 1:32 am

Scortch wrote:Also;

I thought this was interesting...

http://qawet.proboards.com/index.cgi?ac ... ge=3#85846
Yes, very interesting. I notice the post date is Oct 29, 2010, so hopefully, your personal contact information is more up to date.

I noticed the part about rock-steady connections less likely to have the 9014 problem. Some of the Elders of BBA were suspicious of the same thing.
KrispyKritter aka Chatty (glitchy finger) Charlie
Image(pcB)

Post Reply

Who is online

Users browsing this forum: No registered users and 0 guests