Image

Error replaying old 2009 demos

Game Questions and Help / Errors and Game Issues
Post Reply
ETPlayer2019
Newbie
Newbie
Posts: 3
Joined: Mon Feb 04, 2019 12:28 am

Error replaying old 2009 demos

Post by ETPlayer2019 » Mon Feb 04, 2019 12:47 am

**UPDATE** Issue resolved. I placed the demos into ET Legacy instead of ET 2.60b and they work now.

I have a fresh install of ET with Jaymod 2.0.5 (that version is required for these old demos)
And I also added all the necessary map pk3's associated with the demos
I get this error when I try to load my BBA demos from 2009:
ERROR: CG_RegisterPlayerClasses: failed to load character file 'characters/temperate/axis/soldier.char' for the Axis Soldier

and when I press ~ the only line in red says:
ERROR: characters/temperate/axis/soldier.char, line 16: unknown token 'undressedModel'

I checked my pak0.pk3 and the soldier.char file doesn't contain 'undressedModel'

I think all I need is the old (from ~2009) custom pk3 files from BBA. I no longer have those unfortunately, and I haven't been able to locate them on the internet.

EDIT: Forgot to mention that I joined the BBA server today, but it didn't give me any custom pk3's other than jaymod 2.2.0 and some maps. No pk3's with modified character files.
Last edited by ETPlayer2019 on Mon Feb 04, 2019 9:22 pm, edited 1 time in total.

User avatar
bloodbane
Clan Member
Clan Member
Posts: 670
Joined: Wed Dec 31, 1969 7:00 pm
Location: Cleaning your forums spam :P

Re: Error replaying old 2009 demos

Post by bloodbane » Mon Feb 04, 2019 2:28 pm

We have never ran customs skins, outside of some silly Christmas hats and such. My guess would be that you need the version of jaymod that was used at the time.

If you are playing in Jaymod mod for example and you have recorded your game, then it is saved in the “ET/etmain/jaymod/demos/” folder.

When you want to replay your recorded file, just start ET, click on MOD, click on Jaymod (this will restart your game in Jaymod mod), then click on Replays button to see your recorded movies. Recorded movies under Jaymod mod can only be seen, by starting your game in Jaymod mod. The same applies for the other MOD’s also.
Image

ETPlayer2019
Newbie
Newbie
Posts: 3
Joined: Mon Feb 04, 2019 12:28 am

Re: Error replaying old 2009 demos

Post by ETPlayer2019 » Mon Feb 04, 2019 4:24 pm

**UPDATE** Issue resolved. I placed the demos into ET Legacy instead of ET 2.60b and they work now.

I downloaded all the popular versions of Jaymod including 2.2.0; 2.1.7; and 2.0.5
2.0.5 is needed for my old BBA demos and 2.1.7 for a different clan server.
Some demos I had to change the ext from dm_82 to dm_84 for them to appear in the demo list.
I keep getting that axis soldier.char error, I googled it and it appears to be a fairly common and unsolved(?) issue.
I downloaded those older Jaymod versions from wolfenstein4ever.de, maybe they have a faulty file?
One suggestion in another forum was to find a server running Jaymod 2.1.7 there are 2 but those servers are down. And no servers are running Jaymod 2.0.5.
I checked the fu-clan server (where jaymod came from) and they only have version 2.2.0 available for download

I have about 350 BBA demos, all from 2009. Have them stored on an external hdd, separate from my ET installations. And I've been copying them into clean installs of ET, because that's all I have.

Thanks for the reply.

EDIT: Just had a thought. That website where I downloaded those Jaymod verisons from is a German website (.de). At some point Germany banned the Swastika symbol in video games. I wonder if THAT has something to do with it? I'll look for more (non-German) websites hosting those jaymod versions

EDIT 2: I tried downloading jaymod from a different website, this time lonebullet.com
same issue, error with axis soldier.char

EDIT 3 (to clarify): On the main screen, I do click on MODS and select the appropriate mod for the demos, that's not the issue I'm having.

EDIT 4: I've tried to isolate the problem. The issue doesn't appear to be about the demos being old, it's that the jaymod versions have to come from a server using that version as opposed to downloading the jaymod version from some website (I am putting the jaymod folders in the correct path, right aside etmain and it appears in the list of MOD choices on main menu).
I had recently joined a jaymod 2.2.0 server, made some demos, and they work. But when I put those same demos into an installation of ET that I got jaymod 2.2.0 from some website as opposed to direct install via server, then the demos don't work (that soldier.char error).
So I think the issue is that I need older versions of jaymod that were obtained via joining a server, not obtained by wolfenstein4ever.de or other websites. And no active servers use those older versions of jaymod.

User avatar
bloodbane
Clan Member
Clan Member
Posts: 670
Joined: Wed Dec 31, 1969 7:00 pm
Location: Cleaning your forums spam :P

Re: Error replaying old 2009 demos

Post by bloodbane » Tue Feb 05, 2019 1:46 pm

I'm looking at a backup from that era and we had a watermark, custom menus, custom load screen, a "CTF soundpack", and thats it. No character model changes. If there is a particular file you need I can pull it off a backup, but I really really really don't think we have ever had a custom character model loaded.

As to the .DE sites, those rules have been around forever. There are a couple of map sites that closed to lack of interest. It was probably one of those.
Image

ETPlayer2019
Newbie
Newbie
Posts: 3
Joined: Mon Feb 04, 2019 12:28 am

Re: Error replaying old 2009 demos

Post by ETPlayer2019 » Tue Feb 05, 2019 3:51 pm

I didn't exactly solve the issue, but I got around it by using ET Legacy to view the old demos in. For some reason they work in ET Legacy instead, and that's good enough.

Thank you.

Post Reply